WordPress-Update Teil 2

Die Umstellung von ISO-8859-1 auf UTF-8 erweist sich dann doch als etwas komplizierter denn zunächst gedacht.
Tatsächlich sind einige Punkte abzuarbeiten:
– alle Tabellen der WordPress-Datenbank per SQL-Dump in einen guten Editor (z.B. UltraEdit) laden und dort von ASCII in UTF8 konvertieren
– in phpMyAdmin am besten die Tabellen löschen und als UTF8-Tabellen neu importieren oder eben entsprechend jeweils manuell die Struktur ändern (ist aber noch umständlicher!)
– in den WordPress-Ausgabe-Optionen auf UTF-8 umstellen
– in der Datei wpconfig.php (befindet sich im WordPress-Hauptverzeichnis)

define(‘DB_CHARSET’, ‘utf8’);
define(‘DB_COLLATE’, ”);

ergänzen oder entsprechend ändern.

Nach all diesen Kunstgriffen und zwischendurch einige Male Suchen und Ersetzen, um verlorene Umlaute wiederherzustellen, klappt’s dann auch mit UTF-8. Das heißt, daß dann sowohl im WP-Editor als auch im Blog, wie es den Besuchern erscheint, als auch in der MySQL-Datenbank alle Sonderzeichen richtig erscheinen.

Taschentuch bereit halten.

WordPress-Update auf 2.5

Die frisch herausgekommene WordPress Version 2.5 hat mich gereizt. So sehr, daß ich es auf mich genommen habe, mein Uralt-Galerie-Plugin Exhibit in mühevoller Handarbeit rauszuschmeißen. Das heißt, ich mußte alle Posts, die kleine Exhibit-Galerien enthielten, umschreiben und die Einträge in der MySQL-Datenbank entfernen. Denn Exhibit funktionierte schon unter WP 2.0 nur noch eingeschränkt.
Dann habe ich das etwas neuere, aber auch schon nicht mehr wirklich aktuelle MyGallery auf die letzte Version aktualisiert. Dieses Plugin wird offenbar auch nicht mehr gepflegt, da werde ich also noch mal bei müssen. Aber das eilt nicht, denn es funktioniert immerhin noch.
Tja, und dann Datenbank-Backup und das ganze WP-Verzeichnis auf meinem Heim-PC konserviert.
Soviel Sicherheit muß dann doch sein für ein Blog, das bald fünf wird.
Aber nach dem eigentlichen Update war dann nur noch 1 Schritt nötig, um es rund zu machen: die Umstellung auf UTF-8. Denn mit ISO was weiß ich, das ich bislang genutzt habe, wurden im Admin-Menü einige Umlaute nicht richtig angezeigt. Erfreulicherweise sind Postings und Kommentare davon fast unberührt geblieben. Das habe ich bei früheren Umstellungen vom einen auf den andern Zeichensatz auch schon ganz anders erlebt. Jetzt bleibt offenbar nur noch das Update von get_recent_comments, das noch Fragezeichen statt äöü anzeigt ;-)
Alles andere ging einfach so. Reibungslos. Das übliche Database Upgrade und fertig.
Ich finde es toll.